红联Linux门户
Linux帮助

安装完hydra后破解SSH后提示没有libssh的支持,模块不可用

发布时间:2015-07-10 18:40:26来源:红联作者:lixiaopeng
安装完hydra后破解SSH后提示没有libssh的支持,模块不可用:

按照网上提供的解决方案做:

wget
tar zxf libssh-0.4.8.tar.gz
cd libssh-0.4.8
mkdir build
cd build
Cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug -DWITH_SSH1=ON ..
make
make install

安装相关开发依赖包:
[root@Sugon1 bulid]# yum install zlib
[root@Sugon1 bulid]# yum install zlib-devel
[root@Sugon1 bulid]# yum install openssl
[root@Sugon1 bulid]# yum install openssl-devel

安装hydra的依赖包:

yum -y install openssl-devel pcre-devel ncpfs-devel postgresql-devel libssh-devel subversion-devel libncurses-devel



我之前已用网络yum源成功安装过其他包,这里是重复命令。这里唯有ncpfs-devel libssh-devel libncurses-devel 这三个包提示找不到.

然后:


然后:


依然提示libssh没有.

但是:


libssh库已经有了,怎么办?

是不是因为ncpfs-devel libssh-devel libncurses-devel 这三个包没有,他们是hydra软件的依赖包,但到哪里找这三个包?

之前的步骤都是按网上提示一步步走的,但依然有这些问题,该怎么解决?
文章评论

共有 0 条评论

安徽快3 杏彩票计划群 98彩票计划群 万利彩票计划群 极速赛车彩票走势图 千禧彩票计划群 王者彩票开户 极速赛车怎么看计划 山东11选5走势 极速赛车怎么看规律